博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
stars
阅读量:6163 次
发布时间:2019-06-21

本文共 2101 字,大约阅读时间需要 7 分钟。

B - Stars
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
 

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.  
For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.  
You are to write a program that will count the amounts of the stars of each level on a given map.
 

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 

Sample Input

 
5 1 1 5 1 7 1 3 3 5 5
 

Sample Output

 
1 2 1 1 0
 

#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
const int maxn = 32005;
int c[maxn];
int ans[maxn];
int lowbit(int x)  {
    return x&(-x);
}
void add(int x){
    while(x<=maxn){
        c[x]+=1;   x+=lowbit(x);
    }
}
int sum(int x){
    int ret=0;
    while(x>0){
       ret+=c[x];  x-=lowbit(x);
    }
    return ret;
}
int main(){
    int n,x,y,i;
    while(scanf("%d",&n)!=EOF){
        memset(ans,0,sizeof(ans));
        memset(c,0,sizeof(c));
        for(i=0;i<n;i++){
             scanf("%d %d",&x,&y);

             ans[ sum(++x)]++;

             add(x);

        }
        for(i=0;i<n;i++)
        printf("%d\n",ans[i]);

    }

   return 0;

}

转载于:https://www.cnblogs.com/lengxia/p/4387803.html

你可能感兴趣的文章
下一步工作分配
查看>>
Response. AppendHeader使用大全及文件下载.net函数使用注意点(转载)
查看>>
centos64i386下apache 403没有权限访问。
查看>>
jquery用法大全
查看>>
PC-BSD 9.2 发布,基于 FreeBSD 9.2
查看>>
css斜线
查看>>
Windows phone 8 学习笔记(3) 通信
查看>>
Revit API找到风管穿过的墙(当前文档和链接文档)
查看>>
Scroll Depth – 衡量页面滚动的 Google 分析插件
查看>>
Windows 8.1 应用再出发 - 视图状态的更新
查看>>
自己制作交叉编译工具链
查看>>
Qt Style Sheet实践(四):行文本编辑框QLineEdit及自动补全
查看>>
[物理学与PDEs]第3章习题1 只有一个非零分量的磁场
查看>>
onInterceptTouchEvent和onTouchEvent调用时序
查看>>
android防止内存溢出浅析
查看>>
4.3.3版本之引擎bug
查看>>
SQL Server表分区详解
查看>>
STM32启动过程--启动文件--分析
查看>>
垂死挣扎还是涅槃重生 -- Delphi XE5 公布会归来感想
查看>>
淘宝的几个架构图
查看>>